2013 / 2014 / 2015 Ford Escape Forum

2013 / 2014 / 2015 Ford Escape Forum (http://www.fordescape.org/forum/)
-   New Member Introductions (http://www.fordescape.org/forum/new-member-introductions/)
-   -   2014 Ford Escape (http://www.fordescape.org/forum/new-member-introductions/10345-2014-ford-escape.html)

Ratty 12-03-2013 06:10 PM

2014 Ford Escape
 
My wife and I bought a new 2014 Escape and we are having a few problems. We have only owned it for 4 days.

1. We have a strong smell of burning wires.

2. After we turn off the vehicle and everything And open the drivers door a warning sound goes off. Like went you leave the lights on or the keys in the ignition.

3. The horns has sounded a few times when the passangers door is opened when the vehicle is running.

I'm having the Dealer pick-up the car as I do not want to drive it there.

Has anyone else had these problems with there 2014 Escape.

JMR 12-03-2013 06:30 PM

Welcome to the forum, Ratty. Sorry about the problems you're experiencing. I don't know whether anyone here has had the same set of malfunctions, but in any case a possible serious electrical issue (as the "burning wire" smell might indicate) calls for immediate intervention. I think you're doing the right thing by having the dealer check it out.

06SharpGT 12-04-2013 01:07 AM

Definitely have it checked out to be safe. I do know mine had what could be described as a burning smell coming from the engine compartment when new, it was strong enough I could smell it in the cabin, especially when stopped. It slowly faded away after about 1500 miles. I believe it is due to residual oils etc from the mfg. left on the engine block and exhaust components.

Dave2013M3 12-04-2013 04:03 AM

Quote:

Originally Posted by 06SharpGT (Post 124130)
Definitely have it checked out to be safe. I do know mine had what could be described as a burning smell coming from the engine compartment when new, it was strong enough I could smell it in the cabin, especially when stopped. It slowly faded away after about 1500 miles. I believe it is due to residual oils etc from the mfg. left on the engine block and exhaust components.


Thats cosmoline...all manufacturers use it. As you noticed it burnt off after sometime.

Dave

Ratty 12-04-2013 09:56 AM

Yes I do know that smell and unfortunately it was not that. You never forget the smell of burning wires when you have a vehicle catch fire due to that. The Dealer was just here to pick it up and did not seem very happy. I'm hoping that they find it and get it fixed and it is a one time deal.

bjeans 12-04-2013 10:02 AM

Quote:

Originally Posted by Ratty (Post 124282)
Yes I do know that smell and unfortunately it was not that. You never forget the smell of burning wires when you have a vehicle catch fire due to that. The Dealer was just here to pick it up and did not seem very happy. I'm hoping that they find it and get it fixed and it is a one time deal.

I hope the dealer was unhappy with the problem, and not you - and gave you a good loaner. Welcome to the forum, and let us know how it turns out.

jmt9779 12-04-2013 12:02 PM

Quote:

Originally Posted by Ratty (Post 123913)
My wife and I bought a new 2014 Escape and we are having a few problems. We have only owned it for 4 days.

1. We have a strong smell of burning wires.

2. After we turn off the vehicle and everything And open the drivers door a warning sound goes off. Like went you leave the lights on or the keys in the ignition.

3. The horns has sounded a few times when the passangers door is opened when the vehicle is running.

I'm having the Dealer pick-up the car as I do not want to drive it there.

Has anyone else had these problems with there 2014 Escape.

Sorry to hear it, dude. I've had a few problems with mine too since day one (i've only had it 2 months), though, they're different problems.

Anyway, about the horn honking with the door open and the engine running - I found out the hard way recently that if you have the keyless ignition system and take the key outside of the vehicle while it's running, the horn will honk. So, if you have the keyless ignition and the key was in your passenger's pocket and he/she got out of the car with the engine running, that'll do it.

EscapeFan 12-04-2013 12:17 PM

What did you get as a loaner car?
A new Taurus would be sweet!

Ratty 12-04-2013 02:02 PM

Yes always get a loaner when I take my vehicles in for scheduled maintenance. Thank you for asking. We have a side-cut key. I'm starting to wonder if the remote start is the problem. Had the dealer install one.

Before I forget again. Thank you JMR and bjeans for the warm welcome, and to all for things to look at. I hope it is just something simple and it is fix for good.

SRG963 12-04-2013 02:11 PM

Keyless only....If any door opens while parked in neutral, with the car running, the horn will sound twice. It doesn't happen in park, drive, or reverse that I know of, unless the fob is removed from the vehicle as stated above.


All times are GMT -4. The time now is 08:39 AM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.