1Likes
  • 1 Post By pilotattitude
 
LinkBack Thread Tools
#1 Old 08-14-2013, 11:32 AM
Junior Member
 
Join Date: Aug 2013
Posts: 11
Clicking sound during turn(signal lights are on)

Hello again,

I just want to ask if it is normal to hear clicking sound during turns (left or right). I have just experienced this one with my escape titanium during turns with my signals are on I heard this annoying clicking sound but when my signals are off i tried to turn it heard nothing. It only happens during my signals are on. Is this normal. Thank you in advance for your inputs....
edscape is offline  
Sponsored Links
Advertisement
 
#2 Old 08-14-2013, 11:39 AM
Super Moderator
 
pilotattitude's Avatar
 
Join Date: Mar 2013
Location: Long Isle, NY
Posts: 3,938
Garage
Ed, are you talking bout the normal signal tones, heard in all vehicles when your using your signal stalk?

Forum Guidelines

Hey, look. "Esc-a-pay". Hey, it's spelled just like escape

2013 Escape SEL 4WD 2.0 10/2012


FORUM SEARCH CLICK HERE
pilotattitude is offline  
#3 Old 08-14-2013, 11:53 AM
Junior Member
 
Join Date: Aug 2013
Posts: 11
No sir, it is not the signal tones. Its is a clicking sound not coming from the signal tones it is coming from the steering wheel.
edscape is offline  
#4 Old 08-14-2013, 12:03 PM
Super Moderator
 
pilotattitude's Avatar
 
Join Date: Mar 2013
Location: Long Isle, NY
Posts: 3,938
Garage
Funny thing Ed, never noticed it until you mentioned it. I just went outside and tried it out, indeed there is a separate clicking as I spin the wheel with the signal on. So put you at ease your not the only one, lol. Only reasoning I can sum up at the moment is that its electric steering, that it can be some sort of indicator to reset the stalk.
edscape likes this.

Forum Guidelines

Hey, look. "Esc-a-pay". Hey, it's spelled just like escape

2013 Escape SEL 4WD 2.0 10/2012


FORUM SEARCH CLICK HERE
pilotattitude is offline  
#5 Old 08-14-2013, 12:12 PM
Junior Member
 
Join Date: Aug 2013
Posts: 11
I do hope that is the only reason for the clicking issue.. Hope some other member will try also and have some inputs regarding to this matter....
edscape is offline  
#6 Old 10-17-2013, 10:14 AM
Senior Member
 
Join Date: Oct 2013
Location: NYC
Posts: 189
Quote:
Originally Posted by pilotattitude View Post
Funny thing Ed, never noticed it until you mentioned it. I just went outside and tried it out, indeed there is a separate clicking as I spin the wheel with the signal on. So put you at ease your not the only one, lol. Only reasoning I can sum up at the moment is that its electric steering, that it can be some sort of indicator to reset the stalk.
i can't confirm this in my 2014 escape (it's in the shop for a few days for that twitchy steering issue) but my old explorer made this noise specifically for the purpose that pilotattitude mentioned - to reset the stalk.

on my old explorer it was absolutely noticeable - it was supposed to be. i'm guessing with newer cars (like our escapes) they tried to quiet it down a little bit (i noticed even the audible turn signal "clicks" are much quieter on the escape)...which apparently makes it just loud enough to arouse suspicion :-P
jmt9779 is offline  
#7 Old 10-17-2013, 01:10 PM
Senior Member
 
Join Date: Sep 2013
Location: Sammamish WA
Posts: 249
Quote:
Originally Posted by jmt9779 View Post
(i noticed even the audible turn signal "clicks" are much quieter on the escape)...which apparently makes it just loud enough to arouse suspicion :-P
Yes, in fact my wife often says "turn on your turn signal" when I already did, because she can't hear it from the passenger seat.

2014 SE 4WD Deep Impact Blue
2007 Ranger XLT 4x4
1997 Escort

bisjoe is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Popping sound from exhaust during cold start mattwalker1987 Problems & Solutions 63 12-18-2013 10:02 PM
sirius no signal TitaniumEscape Electronics, Audio, and Lighting 6 10-23-2013 09:22 AM
Clunking sound coming from front end mknopick Problems & Solutions 13 05-15-2013 10:59 PM
Instrument cluster humming and clicking mknopick Electronics, Audio, and Lighting 4 04-27-2013 05:35 PM
Fogs lights on SE - auto turn on? Orthobill13 Electronics, Audio, and Lighting 5 04-26-2013 01:26 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On