2013+ Ford Escape Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
835 Posts
Discussion Starter #1
I recently files a complaint with NHTSA!
Everytime I fill my gas tank the engine sputters at idle!!
I now have 88,000 miles no check engine light!
this has gone on for at least 10,000 miles
I know this has to be with the evap valve!
Everyone get on board and complain to "NHTSA"
"Let's get a mandated recall going"
I know how to fix this I just don't feel I should have to pay for it
 

·
Registered
Joined
·
3,531 Posts
I recently files a complaint with NHTSA!
Everytime I fill my gas tank the engine sputters at idle!!
I now have 88,000 miles no check engine light!
this has gone on for at least 10,000 miles
I know this has to be with the evap valve!
Everyone get on board and complain to "NHTSA"
"Let's get a mandated recall going"
I know how to fix this I just don't feel I should have to pay for it
I did mine before I sold it.

I don’t recommend waiting, unless your not driving it. You run the risk of trashing the whole emission system requiring removal of your rear sub frame. But I know you probably know this already.
 

·
Registered
Joined
·
835 Posts
Discussion Starter #4
I changed the Evap valve under hood "fuel vapor assembly" CV6A-9D289-S This is the 6th time this part number has changed! cost me $91.00 with tax
What a mess and a challenge. the Ford parts counter person calls it an "Octopus"
removing the clips was unbelievable "88,000 miles".
removed the cowl and cold air intake tubing, removed the front engine map sensor
Took me over 4 hours to get Octopus out!! The ****** retainer clips!!
I am 69 years old and you should see my hands and arms
Bloodied and bruised all over. Clearance is virtually non existent
Putting the new one on was a cakewalk!
Filled tank with gas and no more sputter after fill up !!
This should be a NHTSA mandated Recall!!!!!!!!!!
The Ford counter man said they replace a lot of these and we read about this on Fusion/ Focus/ Ford Trucks/Escape
 

·
Registered
Joined
·
1,917 Posts
Took me over 4 hours to get Octopus out!! The ****** retainer clips!!
I am 69 years old and you should see my hands and arms
Bloodied and bruised all over. Clearance is virtually non existent
Putting the new one on was a cakewalk!
i struggled as well with the clips. wasn't until i was putting the new part on that i realized i was using the clips wrong.
step 1 was obvious, pull out the locking tab of the clip using a pick.
step 2 is what i couldnt figure out. I was using a pick to pull the tabs apart to get past the bell end of the tube. didn't realize you could just push down on top of the "button" and the tabs would spread apart. and it would pull of the tube with no resistance. super easy.

I could probably replace the whole tube assembly in 30 minutes if i had to do it again.
 
1 - 8 of 8 Posts
Top