2013+ Ford Escape Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I purchased my brand new 2019 Escape September 12, 2019. The vehicle literally had 10miles when I drove it off the lot. During the test run the battery was dead the sale rep tried to give it a good charge for us to drive. The charge took longer than normal so I was assured a new battery (1st battery) will be installed before I took the car home. A month later (Oct 2019) the drive was not as smooth and the brakes didn’t feel right. I took the car back for service and I was told the battery life was low which is why the car was riding sluggish and the problems with the brakes. Again, battery was replaced (2nd battery). Jan 2020 my car took a turn for the worse. The air flow for the AC and Heat was not consistent, I received an error or screen pertaining to the battery again, the lights would flicker and dim, when I come to a complete stop my car will shut completely down but will restart once I pressed on the gas. I turned the off the automatic restart and that seemed to help. I went back to the service department and gave the rep a detail description what was going on and how frustrated I am that this is happening to a NEW car. My car was at the dealership for three days. I was assured again everything was fixed. According to the not so nice service rep, the ground wire had burned out and there was no need to replace the battery. Well Here I am Feb 2020 and now my transmission seems to be having a problem between 1st and 2nd gear. It’s a rough transition and I can hear the car trying to shift. At this point I am ready throw the whole car away. Oh, the air flow through the vents is still not consistent, apple car play doesn’t work and my USB port doesn’t work at all. I can’t believe I am 5 months in and I’m having these problems. I haven’t had my first oil change yet. Has anyone with this year and model having these types of problems?
 

·
Premium Member
Joined
·
1,664 Posts
I purchased my brand new 2019 Escape September 12, 2019. The vehicle literally had 10miles when I drove it off the lot. During the test run the battery was dead the sale rep tried to give it a good charge for us to drive. The charge took longer than normal so I was assured a new battery (1st battery) will be installed before I took the car home. A month later (Oct 2019) the drive was not as smooth and the brakes didn’t feel right. I took the car back for service and I was told the battery life was low which is why the car was riding sluggish and the problems with the brakes. Again, battery was replaced (2nd battery). Jan 2020 my car took a turn for the worse. The air flow for the AC and Heat was not consistent, I received an error or screen pertaining to the battery again, the lights would flicker and dim, when I come to a complete stop my car will shut completely down but will restart once I pressed on the gas. I turned the off the automatic restart and that seemed to help. I went back to the service department and gave the rep a detail description what was going on and how frustrated I am that this is happening to a NEW car. My car was at the dealership for three days. I was assured again everything was fixed. According to the not so nice service rep, the ground wire had burned out and there was no need to replace the battery. Well Here I am Feb 2020 and now my transmission seems to be having a problem between 1st and 2nd gear. It’s a rough transition and I can hear the car trying to shift. At this point I am ready throw the whole car away. Oh, the air flow through the vents is still not consistent, apple car play doesn’t work and my USB port doesn’t work at all. I can’t believe I am 5 months in and I’m having these problems. I haven’t had my first oil change yet. Has anyone with this year and model having these types of problems?
Have not seen others like this. Good thing under warranty. Any other dealers close to get second opinion?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I went to a dealership close to my house and they would not touch my car because the first dealership had already “fixed” the problem. I contacted Ford Corporate office today because at this point I am done with this vehicle.

Have not seen others like this. Good thing under warranty. Any other dealers close to get second opinion?
 

·
Premium Member
Joined
·
1,143 Posts
I'm sorry you've had this bad experience. Please let us know your progress in getting this problem solved. :)
 

·
Registered
Joined
·
818 Posts
Assuming you are in the US. I don't know what the lemon laws are there but surely this would qualify under them or their equivalent?

New car replacement or money back.
 
1 - 5 of 5 Posts
Top