2013+ Ford Escape Forum banner
21 - 26 of 26 Posts

·
Registered
Persian Green 2020 Escape Ti Hybrid
Joined
·
2,481 Posts
btw if that is your car the engine cover is missing.
Ford made a decision to skip them for any hybrids but the Ti due to a parts shortage, the dealer will put one on under your 3/36 warranty.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #22 ·
btw if that is your car the engine cover is missing.
Ford made a decision to skip them for any hybrids but the Ti due to a parts shortage, the dealer will put one on under your 3/36 warranty.

Hey thanks! I never thought twice about it but now that you mention it, most modern cars have a cover overtop.

Does anyone know if the cover is insulated, or is it just plastic?
 

·
Registered
Persian Green 2020 Escape Ti Hybrid
Joined
·
2,481 Posts
It's actually mostly a beauty cover, a few people claim it helps reduce noise.
What I have noticed over Ford models is that any model that has an EB or Hybrid has one, while the others do not (eg the 2.0L Flex fuel in the Focus & the 2.5L in the Fusion).
Knowing Ford's love of de-contenting when models get later in life I always wondered why the hood insulator on the 2019 and 2020 Fusions was pulled, but the engine top cover stayed.
It may have an engineering purpose, it may not, but I still have memories of my '73 Pinto going through starters until I replaced a missing fiber board "stone deflector" that ran across the bottom of the radiator. It was actually there to deflect air to the starter and cool it down since it was basically in an oven due to it being mounted between the exhaust manifold and the exhaust pipe.
 

·
Registered
2020 Escape Hybrid Titanium - The Dark Knight
Joined
·
177 Posts
My Escape does the exact same thing in the first two videos when I remote start and AC is needed. I just assumed it was because it was a hybrid and running off the HVB initially, the noise or "whine" goes away when the car switches to ICE power.

NefCanuck
 

·
Registered
Joined
·
57 Posts
Mine does the same thing, definitely seems like a poor design. I've had frequent people ask me why my car was making that noise during remote-starts.

Once I start driving some it seems to go away even if the ICE off or never turned on (IE - forced EV mode). If I'm at a stop sign or red light after some driving I've rolled down the window and it's silent. As soon as I shut the car off and turn it back on the noise comes back.

 
21 - 26 of 26 Posts
Top