2013+ Ford Escape Forum banner

41 - 48 of 48 Posts

·
Registered
Joined
·
3 Posts
Exact same problem with my 2015 Escape with 60,000 miles. I have an appointment at the dealership and an extended warranty.


Just left the service department. I have a bunch of numbers on the service report, but they replaced 2219D5 Sensor assembly rear - anti- lock REPLACE. I have an extended warranty, so I paid $100.
 

·
Registered
Joined
·
2 Posts
I have a 2015 Ford Escape it overheated a week ago and ever since my Traction Control will start without any reason and the hill assist temporairly not able to use comes on. Also ABS light will not go out.
 

·
Super Moderator
2014 Ford Escape Titanium, 2.0L, Sync 2 MFT
Joined
·
6,067 Posts
I have a 2015 Ford Escape it overheated a week ago and ever since my Traction Control will start without any reason and the hill assist temporairly not able to use comes on. Also ABS light will not go out.
I merged your thread with one of the many existing threads on this issues. Have a look at some of the other posts for some possible help. You can also search the forum for other threads that may help. Should be a quick and easy search to find them.
 

·
Registered
Joined
·
1 Posts
I have the same exact problem with my 2013 Ford Escape 4WD. Started as a knocking noise which turned into the car randomly stalling at stop signs and red lights; it was terrifying because I had no way of knowing when it was going to occur it turns right back on after this occurs. I brought it to the Ford dealership 2 times for this issue, The first time, the transmission tech couldn’t recreate the problem and insisted it was that I needed my transmission fluid flushed which I gave them the go ahead to do. 1 day after getting my car back from them it stalled again so I brought it back a second time. They had my car for almost 60 days and couldn’t figure out what the problem was even though a technician drove the car and it happened to him. They did nothing to fix the issue and had me pay almost $700 out of pocket even with my extended warranty for them to fix absolutely nothing. My car still stalls randomly and is now having the issue with the ABS and traction control light as well as the 4WD and hillside assist issue. The back wheels seem like they’re locking up and the car doesn’t move then a few seconds later and I’m able to drive again. I’m curious if your Ford dealership was able to fix the issue or if you’re still having it as my issue has been ongoing since October 2019; if so what was the issue?
Did you have any resolution with this? Am having The same issue. The dealership said it actually wasn't the ABS sensor it was bc my rear and front tires don't match,causing a reading to skew. Mind you the tires do not need replacing and I don't believe that would be the cause.
 

·
Registered
Joined
·
2 Posts
Recently my abs and traction control warning lights are coming on. Its an on and off thing and sometimes my hill assist light comes on as well. It seemed to start after I took off my winter tires. Any suggestions?
I had that issue and it was my ABS sensor. My husband was able to fix it. Luckily we know someone that has a scanner for codes and was able to tell us which one it was.
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
2,619 Posts
The dealership said it actually wasn't the ABS sensor it was bc my rear and front tires don't match,causing a reading to skew. Mind you the tires do not need replacing and I don't believe that would be the cause.
People on the UK forums have reported iAWD issues (knocking/ banging from a set of lights etc.) with either different brand tyres or one axle set very worn.
 
41 - 48 of 48 Posts
Top