2013+ Ford Escape Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi all,
nice to meet you and feels good to be part of this forum.
i own a 2019 ford escape: titanium edition
i was stopped on the HOV lane in staten Island and i get hit from behind from some small Toyota.
the ford was fine but his car was so low that it went under my ford and his front got messed up big time.

i get out to assess the damage and the lower part of my bumper is cracked from end to end.
the black hard plastic part.. sorta looks like a skirt... it sits on the lower and of the rear bumper.
also now on my console.... the park button stays light "OFF" and when i press the park assist button, a warning comes upn saying there was a fualt then car symbol shows up with a 3redndot on it.. (see photos)
the backup cam works fine.

any ides what this could be?
or how to fix?
could it be the sensors?

76135
76136
76137
 

·
Super Moderator
Joined
·
5,704 Posts
hi all,
nice to meet you and feels good to be part of this forum.
i own a 2019 ford escape: titanium edition
i was stopped on the HOV lane in staten Island and i get hit from behind from some small Toyota.
the ford was fine but his car was so low that it went under my ford and his front got messed up big time.

i get out to assess the damage and the lower part of my bumper is cracked from end to end.
the black hard plastic part.. sorta looks like a skirt... it sits on the lower and of the rear bumper.
also now on my console.... the park button stays light "OFF" and when i press the park assist button, a warning comes upn saying there was a fualt then car symbol shows up with a 3redndot on it.. (see photos)
the backup cam works fine.

any ides what this could be?
or how to fix?
could it be the sensors?
Have you tried to search the forum? There are a few threads that discuss his.
 

·
Super Moderator
Joined
·
1,982 Posts
Do a search on ForScan- a free program that checks for fault codes. It will tell you if there's a problem with a parking sensor, my guess is the sensors in that area have been damaged. Perhaps even the wiring loom?

If you've got the powered tailgate have you checked if it still works? There's a sensor for it in behind the rear bumper.
 

·
Registered
Joined
·
1 Posts
hi all,
nice to meet you and feels good to be part of this forum.
i own a 2019 ford escape: titanium edition
i was stopped on the HOV lane in staten Island and i get hit from behind from some small Toyota.
the ford was fine but his car was so low that it went under my ford and his front got messed up big time.

i get out to assess the damage and the lower part of my bumper is cracked from end to end.
the black hard plastic part.. sorta looks like a skirt... it sits on the lower and of the rear bumper.
also now on my console.... the park button stays light "OFF" and when i press the park assist button, a warning comes upn saying there was a fualt then car symbol shows up with a 3redndot on it.. (see photos)
the backup cam works fine.

any ides what this could be?
or how to fix?
could it be the sensors?

View attachment 76135 View attachment 76136 View attachment 76137
Sounds like some sensors were damaged.
 
1 - 5 of 5 Posts
Top