2013+ Ford Escape Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2017 Escape. The car was not used for about a month and the battery died. After jumping it, it started right up but the entire climate control system would not turn on. Everything else on the dash works except the volume for Bluetooth is very low and doesn't respond. Could this be a fuse issue or a more substantial problem with a module?
 

·
Super Moderator
2017 Escape Titanium 2.0l Ecoboost
Joined
·
1,324 Posts
I'd try charging the battery and then see if any problems persist. Some features will shut down when the computer is saying that the battery voltage is low.
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,910 Posts
Is the Sync 3 (8" screen) working and the Heating Ventilation Air Conditioning dedicated control panel (lower on the centre console) the bit not working?

If it's like the earlier Sync 2, there's a power switch to turn on the HVAC system. Could that be off?
 

·
Registered
Joined
·
3 Posts
Did you ever solve this issue? I just had the same problem. Dedicated control panel, no power, no lights. Started after getting jumped (-38 temps). I sat the vehicle for a couple hours attempted to drive but could not defrost windows due to this. I have tried a power cycle, turned off and waited 30 mins. Vehicle is currently off and block plugged in. Is there a fuse I can check would a fuse blow with this conditions?

Thanks
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,910 Posts
Thanks for posting the resolution. Do you recall which fuse it was?
 

·
Registered
Joined
·
121 Posts
I'm hoping this is what just happened to mine. Just got the battery replaced at the dealer. Started driving home and no climate control. Brought it back they better not charge me.
 
1 - 8 of 8 Posts
Top