2013+ Ford Escape Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
My 2017 Titanium Escape has had the center screen go blank, no radio or nav, two times so far as well as the right side steering wheel buttons not working and no rear view camera. Everything south of the screen is working and the car seems to run fine. After sitting off for awhile the screen does come on again and everything behaves as normal. If I turn the car off and then back on when it first goes blank, however, the screen and the other things still don't work.
Anyone have any ideas as to why this would happen?
 

·
Premium Member
Joined
·
2,205 Posts
Not sure what is wrong but since it is new I would take it in for service. If it happens again I would take a photo of the blank screen to show the service writer.
 

·
Registered
Joined
·
706 Posts
I agree with @SteveTurbo, I would take it to the dealer as this doesn't sound like something that happens often to folks on this forum (not that I've read on here at least). A picture or a video of you trying to press buttons and other things to show that it is not working will be good to have. Most probably, they will not be able to replicate this once the vehicle is at the dealer so it's best to have the pictures or video to show them.
 

·
Registered
Joined
·
135 Posts
The "screen" is a computer, do a factory restore, then sync your phone again and see if it stops. A reset fixes a lot of glitches.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #6 ·
Thanks all for the info. I didn't think to take a picture of the blank screen but that is a great idea. I talked with a Ford dealer here in the Syracuse NY area and they said to bring it in if it happens again.
 

·
Registered
Joined
·
3 Posts
I did take a video to show them what it was doing, they can't get it to do it! Can't fix until they get a code I think it's a short in the system!
 

·
Premium Member
Joined
·
1,929 Posts
I did take a video to show them what it was doing, they can't get it to do it! Can't fix until they get a code I think it's a short in the system!
Does the 2017 have a “DISP” button like my 2018? If so, try hitting it and wait a few seconds and press it again.
 

·
Registered
Joined
·
3 Posts
I have a 2019 Escape I'm unsure about a reset button I'll check though. It's going in tomorrow for an oil change I'll bring up the issue again. We drove 20 miles and the screen flipped from white(normal) to black 14 times.
 

·
Registered
Joined
·
63 Posts
Susan, I think what you're describing is normal. Mine does this all the time when the lighting conditions change. As it's getting dark, mine is always changing - probably the sunlight sensor is sensing light, then dark, then light, then dark, as you corner and change directions you are changing the way the light hits the sensor and it is adjusting the screen as best it can. It can be set to day, night, or auto. Setting to day or night will alleviate that. Also when auto dim is set my screen will flicker as well, as the sun is beginning to go down.
 

·
Registered
Joined
·
3 Posts
Susan, ours does that too but only started doing it after owning it and driving it for 1 1/2 yrs. Weather and sun have not changed while it goes crazy changing back and forth from blue to black to white or variations of . Started when the stop start feature stopped working. They changed battery and fixed stop start but not the changing screen. If it is normal why did not this happen from day one?
 

·
Registered
Joined
·
1 Posts
I have 2017 Escape brought it to the dealer for a program update (19B37) and had the car detailed. When I went to pick up the car the display screen in the center of the instrument cluster was blank but white not black. The dealer said it was a coincidence and had nothing to do with them. It worked fine when we dropped it off and now it doesn't . I think either the program did something or the detail shop sprayed the screen by mistake . Anyone else have this issue?
 
1 - 12 of 12 Posts
Top