2013+ Ford Escape Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #21 ·
A full battery test takes a little over an hour by Ford, it sounds they are only doing a quick test. In my F350, I run a 850 CCA Battery when standard is a 650. I had a new 850 ( with 6 yr warranty ) from Ford and within a year, my truck wasn't starting in the mornings. I had it tested a couple times at Ford and they said it was fine. It continued it's ritual in not starting so back to Ford I went. The Service Manager said I could have a full test done which would take 60-90 minutes. If the battery was bad, they would replace it under warranty, if it was good I had to pay for the test. It had 1 bad cell, I got a new battery. So ya, you can buy a good battery and they still can go bad. If you don't like one dealer, try a different one.
Thank you so much
 

·
Registered
Joined
·
2 Posts
Hello,

Got a 16 Titanium and recently replaced the OEM battery (4 months ago) since then the battery has died completely twice. We use the car daily most week if not at least 4-5 days a week.

Is it normal for a battery to lose all charge after not being used for max 3-4 days? (new battery installed 4 months ago)

The only thing I can notice without any advanced diagnostics is a buzzing sound that can be heard from the CD insert slot on top of the radio. Always thought it was sort like if the motor was spinning to see if there was any disc there.

Is this normal? Is there a chance of parasitic battery draw somewhere?

Thank you
 

·
Administrator
2014 Ford Escape Titanium, 2.0L, Sync 2 MFT
Joined
·
5,513 Posts
Hello,

Got a 16 Titanium and recently replaced the OEM battery (4 months ago) since then the battery has died completely twice. We use the car daily most week if not at least 4-5 days a week.

Is it normal for a battery to lose all charge after not being used for max 3-4 days? (new battery installed 4 months ago)

The only thing I can notice without any advanced diagnostics is a buzzing sound that can be heard from the CD insert slot on top of the radio. Always thought it was sort like if the motor was spinning to see if there was any disc there.

Is this normal? Is there a chance of parasitic battery draw somewhere?

Thank you
I merged your thread with this existing thread on the same topic. Have a look at some of the other posts for possible help.
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,173 Posts
Is it normal for a battery to lose all charge after not being used for max 3-4 days? (new battery installed 4 months ago)
No, it's not normal. Do you know if they reset the Battery Management System when the battery was replaced? Do you leave anything plugged into the cigarette lighter power outlets- they're always powered.
 
  • Like
Reactions: Vader101
21 - 24 of 24 Posts
Top