2013+ Ford Escape Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi new to the forum! first the vehicle information 2016 Ford Escape SE 30K miles, I bought this to my daughter about 4 or 5 months ago as used, recently about a month ago start to turn on the hill assist and ABS warning Light, get the vehicle to inspect in Advance, well brakes ok, the change rear struts, all was fine nothing wrong found, I understand is Advance not a Ford shop, well recently the millage gauge stop to work, ABS light and hill assist turn on and the the steering wheel get to hard to turn, like the power steering pump stop working, the strange thing is that you turn off the car and started again and all works perfect again , today I try to reset again and the gauges turn crazy go down and up, any experience or advice what I can verify prior to get it to the dealer to waste thousand of dollars?
 

·
Registered
Joined
·
105 Posts
How old is the battery? Has it been replaced recently?

If not, it may be in line for a new battery. If it has, it's likely the battery management system needs to be reset.

With these vehicles, it seems that any weird electronic glitch can 80% of the time be traced back to a BMS failure.

Sent from my SM-N975U using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks for the reply, Thinking about it went I purchase the vehicle they have to use a boost to start up, I request a new one but you now how the dealer is " that's battery is ok" thanks a lot going to buy a new one today
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
How old is the battery? Has it been replaced recently?

If not, it may be in line for a new battery. If it has, it's likely the battery management system needs to be reset.

With these vehicles, it seems that any weird electronic glitch can 80% of the time be traced back to a BMS failure.

Sent from my SM-N975U using Tapatalk
Other thing I see "battery management system needs to be reset." there's a procedure for that or with the new battery process is done?
 

·
Administrator
2014 Ford Escape Titanium, 2.0L, Sync 2 MFT
Joined
·
5,364 Posts
Other thing I see "battery management system needs to be reset." there's a procedure for that or with the new battery process is done?
Search for “DIY Battery Management Reset”. If you have any more questions on the BMS Reset, please post it in that thread.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Well i do my assignment do the BMS without results vehicle continue with same issues, i think i have to continue the post here, moderator if not let me know please.
Can anyone tell me if a can check the ABS Tone ring on this year 2016 ford escape se, im making research but not found something regarding 2016 year
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,091 Posts
So you've replaced the battery and done the BMS reset? Have you checked the battery terminals for corrosion- particularly the negative terminal (which is the hardest to see?) It has the BMS sensor on it and is known to corrode and fail- with the two small wires going to it often breaking off.

I'd suggest also looking into ForScan (searching should find info) as that's the best program to scan for faults via the OBD2 connector.
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
3,091 Posts
Okay, so note them down and do a reset. See what reappears.

Did you also check the battery terminals as you'll get random electrical faults if the vehicle power isn't stable.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Thanks for the reply going to do it this week and post reply, that's a good idea because I see some of them says not present at time of request, other intermittent at time of request, let's try the reset to verify and also verify that negative cable , thanks!
 
1 - 11 of 11 Posts
Top