2013+ Ford Escape Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all thank you in advance for the help
I have a 2015 Ford Escape and it is been to the local Ford dealer twice for the front signal light not working..

The rear works but not the front signal

Trip 1 replaced the bulb although I had just replaced it

Trip 2 replaced the bulb and socket

I believe it is something with wiring because it works intermittently ... all of a sudden it will work for few moments then stopped working for a week then work again then stop for a long duration once again

Are there any known issues with this... I thought I had read some where about wiring problems in the steering column ??.?

I'm nervous to take it back into the dealer
Thank you
 

·
Super Moderator
2016 Kuga Titanium 2.0l EcoBoost
Joined
·
2,616 Posts
Welcome to the forum.

From memory the indicators on each side originate from the same wiring point on the BCM (Body Control Module - which is the back section of the fuse box located under the glove box.) So if the rear is working it points to a wiring/ bulb/ light problem after the Body Control Module.) It could be a bad/ dirty contact in a plug or the light socket, or rodent damage to the wiring?

PS: I assume you're talking about the turn signals/ indicator lights? Different terminology in countries can confuse things. ;)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you for the information
Yes that's correct turn signals
The dealership did replace the socket and bulb but I don't know how far back they checked the wiring

Good to know that if the rear is working (which it is) that checking the wiring if the next best step
Thank you
 
1 - 3 of 3 Posts
Top