2013+ Ford Escape Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Noticed this for the first time on my 2020 Titanium AWD yesterday. No idea what it means, but the Nav display was actively showing the current car location on the map while I was driving so I didn't think about it too much then. I was not using any navigation functions at the time - just had the display open.

Today the wife is driving and just called me to say the the Nav system is all messed up. She sees the same red circle/slash on the display, and she is actually trying to use the Nav system for directions but it is giving her fits.

Anybody else seen this? I wonder if it is related to the recent Ford software updates, or if my car is having a stroke? I haven't yet tried to any further research on this - came here first to see if it is special just for me.
 

·
Registered
Persian Green 2020 Escape Ti Hybrid
Joined
·
2,368 Posts
It means the APIM cannot see the GPS antenna located in the shark fin.
Check and see if you Sirius XM is working (even without service you'll still get the AD to play) or not.
We had this happen and it was caused by water getting into the antenna.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
Thanx for your reply. Ain't been no rain here for about 75 years, so unlikely to be a water issue. But other research does indicate a likely APIM failure, so I'll just take it in and let the dealer handle it. At least I know that it is not a mass failure caused by a recent software update.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #6 ·
Thanks for the responses and ideas. My car is working again today, so I guess I'll just have to keep an eye on it for maybe a future APIM failure. Can't fix it while it's working!
 
1 - 6 of 6 Posts
Top