2013+ Ford Escape Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Anyone experienced long miles? I got own 2014 Escape titanium 2.0l awd been longest 133k miles so far no trouble! and been wondering anyone have trouble show up normally worn out or else? Please be patient I am new members! Thank you!
 

·
Super Moderator
2017 Escape Titanium 2.0l Ecoboost
Joined
·
1,194 Posts
Welcome to the forum, Maka82Escape! You've posted in a sub-forum that is for introductions only. You might want to ask your question here: 3G Ford Escape General Discussion
 

·
Administrator
2014 Ford Escape Titanium, 2.0L, Sync 2 MFT
Joined
·
6,076 Posts
Anyone experienced long miles? I got own 2014 Escape titanium 2.0l awd been longest 133k miles so far no trouble! and been wondering anyone have trouble show up normally worn out or else? Please be patient I am new members! Thank you!
Welcome to the forum. Check out this related thread. FYI, the new member introductory is just for introducing yourself and your Escape. I moved your thread to the 3G General Discussion sub forum.

Escape Ecoboost 2.0 high mileage ... post it up !
 

·
Registered
Persian Green 2020 Escape Ti Hybrid
Joined
·
2,245 Posts
It all comes down to how the vehicle was maintained and driven.
At 133K if it hasn't been done already you should be expecting to replace the belts, a coolant flush, transmission fluid replacement and spark plugs/coils needing to be replaced.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Anyone experienced long miles? I got own 2014 Escape titanium 2.0l awd been longest 133k miles so far no trouble! and been wondering anyone have trouble show up normally worn out or else? Please be patient I am new members! Thank you!
It all comes down to how the vehicle was maintained and driven.
At 133K if it hasn't been done already you should be expecting to replace the belts, a coolant flush, transmission fluid replacement and spark plugs/coils needing to be replaced.
I already tune up spark plug and coils but will plans buy new belt too. So I will have to consider about flash fluid transmission and coolant whenever I have time. By the way I very OCD maintenance on my suv daily. Pretty good run long last. Thank for nice feedback!
 

·
Registered
Joined
·
35 Posts
I have 190K on my 2013 1.6L and it's never been rebuilt. I've had it since 89K and it was great until about a year ago and then everything started to fall apart. Most of the sensors had to be replaced, some radiator hoses started leaking and then the transmission went out. It runs ok now but I still have some minor issues that need to be addressed. Mine was a bad year for the escape, not sure about yours.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
I have 190K on my 2013 1.6L and it's never been rebuilt. I've had it since 89K and it was great until about a year ago and then everything started to fall apart. Most of the sensors had to be replaced, some radiator hoses started leaking and then the transmission went out. It runs ok now but I still have some minor issues that need to be addressed. Mine was a bad year for the escape, not sure about yours.

interesting! That sucks about your bad luck escape with 1.6l sorry buddy, hopefully you will able help fix up? Mine 2014 escape titanium awd with 2.0L turbocharged are strong runs and just I got new tires on rear no **** expensive price in CT. I already tune up was good so I keep remind me need buy new belt soon and also haven't do flash fluid anything for now.
 
1 - 8 of 8 Posts
Top