2013+ Ford Escape Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello I was wondering if anyone has had the same problems I am having. While under hard acceleration my escape will kick like the motor is misfiring. It also does this while driving down the highway mainly going up hills in 6th gear. If I manually shift into 5th gear before going up the hill it does not kick. I am not getting any codes from the obd port. The other problem I have is when I come to a stop at a light I can hear a knocking coming from under the hood but it stops as soon as I put the vehicle in neutral.

2013 ford escape titanium ecoboost AWD
 

·
Registered
Joined
·
106 Posts
I'm assuming you have the 2.0. This is a shot in the dark, but the "kick" might just be a downshift.
 

·
Registered
Joined
·
3 Posts
Hello I was wondering if anyone has had the same problems I am having. While under hard acceleration my escape will kick like the motor is misfiring. It also does this while driving down the highway mainly going up hills in 6th gear. If I manually shift into 5th gear before going up the hill it does not kick. I am not getting any codes from the obd port. The other problem I have is when I come to a stop at a light I can hear a knocking coming from under the hood but it stops as soon as I put the vehicle in neutral.

2013 ford escape titanium ecoboost AWD
My wife's does this same thing. This car is new to us (less than a week) and it threw the abs, 4 wheel inop, hill assist lights the second day we had it. I was hoping that it was related to the abs/ speed sensor. Our car needed brakes all the way around and after doing all 4 wheel sensors, and complete brakes ( rotors, pads and calipers) I hoped the acceleration issue would be resolved. No such luck. If you figure out the issue please let me know. And I'll do the same for you.

Good luck to us both.

Doug
 

·
Registered
Joined
·
1 Posts
Hello I was wondering if anyone has had the same problems I am having. While under hard acceleration my escape will kick like the motor is misfiring. It also does this while driving down the highway mainly going up hills in 6th gear. If I manually shift into 5th gear before going up the hill it does not kick. I am not getting any codes from the obd port. The other problem I have is when I come to a stop at a light I can hear a knocking coming from under the hood but it stops as soon as I put the vehicle in neutral.

2013 ford escape titanium ecoboost AWD
I bought a 2013 Titanium and it would kick took me awhile to find out it was the engine mounts were worn out. replaced 2 of then. One on passenger side and the rear one cost like $70 for both and replaced them myself. No more kicking. You can check mounts by lifting hood, start car and pump rev it and see if the engine is moving or twisting in engine bay. A little is ok. Search youtube on how to replace.
 

·
Registered
Joined
·
3 Posts
I bought a 2013 Titanium and it would kick took me awhile to find out it was the engine mounts were worn out. replaced 2 of then. One on passenger side and the rear one cost like $70 for both and replaced them myself. No more kicking. You can check mounts by lifting hood, start car and pump rev it and see if the engine is moving or twisting in engine bay. A little is ok. Search youtube on how to replace.
I'll check that out tonight when I get home from work, appreciate the heads up
 
1 - 5 of 5 Posts
Top