2013+ Ford Escape Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi. I recently bought a Rockville USS10 to upgrade the bass in my 2017 Escape Titanium with the Sony Sound System and SYNC3. I got it connected to the battery and to the ground, but I do not know exactly what to do to get the sub connected to the stock media player. All I want is to get the new sub connected in place of the stock one, but the connections are not plug and play and I want to get advice before I begin so I dont screw anything up. I have included pictures of the plugs, connectors, the sub and wires I have, and the connections to the stock subwoofer. Would it be possible for me to connect the new sub in the rear cargo area using the stock subwoofer connector and splicing in the cables, and if so, which colors go to which cable? Should I splice it from the back of the sync module? Do I need any special parts to make the connections? I was quoted 130$ for this job, and I would rather put the time in and do it myself than I would spend that. Any advice or instruction would help, even if you used a different method because it still might help. Anyone who knows which of the wires that plug in to the green connector(white,white/blu,white/gray,white/black) is the left or right positive or negative that would also be a huge help. Thanks in advance!
77938
77939
77940
77941
77942
77943
77944
77945
rearplug.PNG
 

·
Registered
Joined
·
99 Posts
From what it looks like, thehe picture labeled "wire" connects to the left (green) connector in the "rear" picture.

Then you connect the bare wire into the "High Level" connector on the sub.

Did you do any research on these parts before buying them? Just want to make sure you're not trying anything that will cause issues.

Sent from my SM-N975U using Tapatalk
 
1 - 2 of 2 Posts
Top