2013+ Ford Escape Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I am running a very aggressive tune on my 2016 ford escape and she makes upwards of 22 psi of boost on hard acceleration i am running into a problem where at around 55 just after shifting into third the ecu automatically limits the boost to 5 psi and i loose alot of power. This can simply be fixed by clearing the ecu code from my tuner unit but its annoying because it happens frequently, is there any way to disable the overboosting sensor so i can properly run 0-60 times?
 

·
Premium Member
Joined
·
1,669 Posts
What kind of tuner are you working with?
 

·
Premium Member
Joined
·
1,669 Posts
Did you check your car for a boost leak or check if your pipes are on tightly? I know that the Focus RS/ST have overboost to protect their motors but to drop all the way to just 5 psi from 20+ psi is a lot. Reading the forums of other Ecoboost forums it seems as if overboost is something a tuner can try to trick the system into not seeing but cannot be tuned out completely. Then again many of the forums I read were from 2-3 years ago so I think the best option would be to call Livernois and see what they can do about it. Usually places will give you a free tune if a person is having issue with the first one. Good luck!
 
  • Like
Reactions: murcod

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Eh i disconnected by intake boost sensor so it works now. it no longer overboots and limits the turbo because it can no longer sence the intake pressure. It's not perfect but it works.
 
1 - 5 of 5 Posts
Top