2013+ Ford Escape Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello,

I have a 2020 SE Sport Hybrid with the latest build of Sync 3.4 (build 20282). Since I got the car last summer, SiriusXM has been delayed to start whenever I start the car. Sometimes it takes 1-2 minutes before I can reliably toggle between channels with and also I have the channel icons appearing. I’ve attached a video - pardon the navigation interruption! What you see in the video is standard pretty much every time I start the car (unless I just stopped it a few minutes ago to run into a gas station or something - it starts back up quickly then).

Is this pretty standard? It’s quite frustrating, as other cars I’ve been in with SiriusXM connectivity start right up. Also, lest anyone wonder, I had an unobstructed view of the sky, though today it was cloudy. It does the same thing on a sunny day with a clear sky.


Thank you!

 

·
Premium Member
Joined
·
1,760 Posts
I had no issues in the summer but as the weather has gotten colder and worst I had some issues. I do have a 2019 car but I would guess that wouldn't affect the playablity of Sirus Radio.
 

·
Registered
Joined
·
39 Posts
Mine usually starts up within 10 seconds - even under a covered garage
 

·
Registered
2020 Ford Escape Titanium/AWD
Joined
·
60 Posts
It's buggy. 20136 did not have this issue.

I thought it was better with this version, but I got pretty much exactly what you showed today.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
It's buggy. 20136 did not have this issue.

I thought it was better with this version, but I got pretty much exactly what you showed today.
Have you by chance taken yours in to have it checked? I’m considering doing so to see if there’s a problem with the SiriusXM antenna/signal.
 

·
Registered
2020 Ford Escape Titanium/AWD
Joined
·
60 Posts
I'm going in Wednesday. FordPass told me my modem wasn't working.

FordPass also had me do a Master Reset and Sync has been 'weird' since then, but it may just be that it's slowly optimizing. My Sirius logos are finally coming back after the reset.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
I'm going in Wednesday. FordPass told me my modem wasn't working.

FordPass also had me do a Master Reset and Sync has been 'weird' since then, but it may just be that it's slowly optimizing. My Sirius logos are finally coming back after the reset.
Find anything out?
 

·
Registered
2020 Ford Escape Titanium/AWD
Joined
·
60 Posts
They still have my car. They had to order a TCU for it. I don't know if that has something to do with GPS, but I was losing it frequently too.

Since I've had to go in so much early on, they just told me to keep the loaner until everything is done. They are fixing more speaker rattle as well.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
They still have my car. They had to order a TCU for it. I don't know if that has something to do with GPS, but I was losing it frequently too.

Since I've had to go in so much early on, they just told me to keep the loaner until everything is done. They are fixing more speaker rattle as well.
What a mess!
 

·
Registered
2020 Ford Escape Titanium/AWD
Joined
·
60 Posts
I won't lie, I'm pretty patient, but I've had more issues with the 2020 Titanium than my 2007 & 2017 Escape combined.
 
1 - 10 of 10 Posts
Top