2013+ Ford Escape Forum banner

41 - 56 of 56 Posts

·
Registered
Joined
·
1,327 Posts
About to buy a Titanium Hybrid... should I be worried??
Haven't had any issues here. I have an early March build. They'd have to apply the fix anyway before they sold it to you.
 
  • Like
Reactions: brunoschca

·
Registered
Joined
·
8 Posts
I love mine,

I got it on Jan 4th. I drove 4,000 miles before we went on lock down, so very few miles in the last 3 months. The only good thing is i am under by 4,000 miles in my lease!!
The only issue i have seen is my Sync is sluggish and has locked up 3 times. Have to have the dealer look at it.

I average about 38MPG REAL MPG not going by what the dash says. The dash says i am getting 40.
I always drive in ECO mode, and have a mix of Highway and city.

When i just run around town i get about 45mpg Escape_Front.jpeg
 

·
Registered
Joined
·
8 Posts
Haven't had any issues here. I have an early March build. They'd have to apply the fix anyway before they sold it to you.
Are you having any issues with your Sync?
What type of MPG are you getting with yours?
I have not had the dealer perform the fix yet. Did you notice any difference when the fix was completed?
 

·
Registered
Joined
·
75 Posts
Haven't had any issues here. I have an early March build. They'd have to apply the fix anyway before they sold it to you.
I had the “Stop safely” Case happen once, three months ago. I got a recall notice from Ford two weeks ago. Had the dealer visit last week.

Bought my SE Sport hybrid on 12/18/2029. Love the car.
 

·
Registered
Joined
·
1,327 Posts
Are you having any issues with your Sync?
What type of MPG are you getting with yours?
I have not had the dealer perform the fix yet. Did you notice any difference when the fix was completed?
I'm running a later software release, the one that sounds like it'll show up for you to update to (20136) in July judging from OASIS notices.

My wife drives most, normal mode, short trips, getting 39 MPG overall. I pull upper 40's to low 50's in Eco mode myself.

Mine was built post-fix by a couple days, so I've never had the SSN issue, or anything else powertrain related.
 

·
Registered
Joined
·
75 Posts
Yes, I received an official mailing from Ford about the “stop safely” issue.
 

·
Registered
Joined
·
8 Posts
I'm running a later software release, the one that sounds like it'll show up for you to update to (20136) in July judging from OASIS notices.

My wife drives most, normal mode, short trips, getting 39 MPG overall. I pull upper 40's to low 50's in Eco mode myself.

Mine was built post-fix by a couple days, so I've never had the SSN issue, or anything else powertrain related.
Can i ask you what an OASIS notice is?
My past escapes usually pull down new software when it comes out when i am in my garage connected to the Wifi

I have this one flat route i take, which is about 10 miles, i usually get a trip MPG of about 70 for that 10 mile stretch!
 

·
Registered
Joined
·
1,327 Posts
Can i ask you what an OASIS notice is?
OASIS is the dealer tech utility. It's where Ford can push out service notices, etc. for the techs. So, for example, one causing me headaches:

SSM 48864 - 2020 Various Vehicles - Equipped With SYNC 3 - System Stating "In Michigan" When Using Push To Talk Navigation

Then it has any information on that SSM, like impacted models, planned fix timing if known, etc.
 

·
Registered
Joined
·
8 Posts
OASIS is the dealer tech utility. It's where Ford can push out service notices, etc. for the techs. So, for example, one causing me headaches:

SSM 48864 - 2020 Various Vehicles - Equipped With SYNC 3 - System Stating "In Michigan" When Using Push To Talk Navigation

Then it has any information on that SSM, like impacted models, planned fix timing if known, etc.
[/QUOTEThats interesting, I have tried to find addresses using voice commands and it keeps defaulting to Michigan!!
 

·
Registered
Joined
·
1,327 Posts
You’re not alone. I’ll PM you a workaround so we can let this thread go back on topic.
 

·
Registered
Joined
·
75 Posts
Yesterday, the problem happened to me for the second time since I bought the car and the first since the problem was supposedly fixed.
 

·
Registered
Joined
·
1 Posts
My 2020 Escape AWD has the same problem. It has been in the shop for a month now. Dealer just called, they found no problems, and I can come pick the car up.

3700 miles and already has problems.
 
41 - 56 of 56 Posts
Top